Utiliser glulxe avec gargoyle

Pour parler des fictions interactives auxquelles vous jouez, demander de l'aide ou une solution, ou pour démarrer en fiction interactive (commandes, interpréteurs, etc.).

Modérateurs: Stormi, Otto Grimwald

Utiliser glulxe avec gargoyle

Messagepar chat-loupe le Dim Juil 29, 2007 9:20 am

Bonjour :D

Je voulais tester le jeu "Lieux Communs", ravi que j'étais de trouver enfin une fiction interactive en français, et autour de Lovecraft, en plus ! (merci aux auteurs :) ).

J'ai donc téléchargé la version Linux de gargoyle et je peux lancer le jeu par :
Code: Tout sélectionner
gargoyle lieuxcommuns.blb


Mais je lis là :
http://informfr.tuxfamily.org/README_Lisezmoi.html
qu'il faut préférer le moteur glulxe au moteur git. Comment fait-on pour utiliser glulxe à la place de git ? J'ai tenté sans conviction de lancer :
Code: Tout sélectionner
./glulxe lieuxcommuns.blb

Mais je récupère le message d'erreur :
Code: Tout sélectionner
./glulxe: error while loading shared libraries: libgarglk.so: cannot open shared object file: No such file or directory


Faut-il recompiler gargoyle avec l'option qui va bien ?

Merci d'avance pour votre aide !
chat-loupe
 

Messagepar Otto Grimwald le Dim Juil 29, 2007 10:12 am

salut,

Dans la version zippée de lieux communs pour windows on a mis une version allégée de gargoyle avec le moteur glulxe directement.

Mais vu la teneur de ton message, je présume que tu es sous linux.
En fait il n'y a rien de compliqué à faire, il suffit de modifier le fichier gargoyle qui n'est en fait qu'un script pour appeler les autres exécutables, et tu remplaces toutes les occurences de git avec glulxe à la place.

Si tu utilises un système à base debian, j'ai fait un paquet pour l'installation ici : (avec la modification nécessaire ) :

http://ifiction.free.fr/fichiers/gargoyle_i386.deb

je vais bientôt le modifier car il y a un patch de sorti :
http://groups.google.com/group/rec.game ... 4c1074de2e

Avatar de l’utilisateur
Otto Grimwald
Très Ancien
 
Messages: 3028
Inscription: Mar Aoû 24, 2004 12:02 pm

Messagepar Invité le Dim Juil 29, 2007 10:30 am

Otto Grimwald a écrit:Mais vu la teneur de ton message, je présume que tu es sous linux.

Oui :)

En fait il n'y a rien de compliqué à faire, il suffit de modifier le fichier gargoyle qui n'est en fait qu'un script pour appeler les autres exécutables

Ah oui, je n'avais pas fait attention à ça ! :?

, et tu remplaces toutes les occurences de git avec glulxe à la place.

J'ai ajouté une ligne spécifique à lieux communs dans le case :
Code: Tout sélectionner
lieuxcommuns.blb)
        $dirpath/glulxe "$1" ;;

Comme ça, je verrais au cas par cas. A moins que le bug ne touche tous les jeux dans ce format-là ?

En tout cas, merci !
Invité
 

Messagepar Otto Grimwald le Dim Juil 29, 2007 11:12 am

je viens de poster à l'adresse précédente une version mise à jour de glulxe et de git pour gargoyle (paquet debian). Je ne sais pas si ce patch corrige tous les bugs en fait. J'ai ajouté une version qui s'appelle gargoyle-git qui permet d'utiliser git à la place de glulxe directement. Le seul avantage de git est qu'il est plus rapide, en tout cas vu comment cela crashait de partout sur plusieurs jeux, cela me dissuade de l'utiliser...

J'ai généré automatiquement un paquet rpm qui se trouve ici, mais je ne sais pas ce que cela vaut :

http://ifiction.free.fr/fichiers/gargoy ... 3.i386.rpm

Avatar de l’utilisateur
Otto Grimwald
Très Ancien
 
Messages: 3028
Inscription: Mar Aoû 24, 2004 12:02 pm

Messagepar chat-loupe le Ven Jan 30, 2015 3:23 pm

Je suis sous Mandriva donc je pourrais tester le rpm mais, euh, je préfère m'en tenir au gargoyle installé à la main dans mon HOME. Je suis du genre hyper prudent :P
Sujet remonté par Anonymous le Ven Jan 30, 2015 3:23 pm.
chat-loupe
 


Retourner vers Discussion sur les fictions interactives

Qui est en ligne

Utilisateurs parcourant ce forum: Bing [Bot] et 1 invité

cron